Accès definition attribut

4.0
Accès definition attribut
0
Tags: #<Tag:0x00007f13db875b18>

#1

Bonjour,
Je viens de me rendre compte qu’un utilisateur qui n’appartient qu’a un groupe que j’ai créer et qui n’a donc normalement pas le droit de voir les attribut ou au moins les spécificités de chaque attribut peut les voir.
Il ne peut rien modifier mais a accès à toutes les informations.
Je ne sais pas si c’est normal …
En tout cas, j’aimerai que mon utilisateur ne puisse pas y accéder (que si il clique sur le nom de l’attribut il n’arrive pas sur le formulaire de l’attribut), en effet il y a le nom physique ou ce type d’information qui sont un peu sensibles…
Comment puis je faire ?

Merci d’avance
Laurre


(David AZOULAY) #2

Un utilisateur qui n’a pas été habilité d’une manière ou d’une autre à l’objet système Field n’a pas accès au paramétrage des attributs.

Vous avez du donner trop de droits à cet utilisateur, soit directement au niveau de ses responsabilités, soit dans le profil d’un des groupes de ses responsabilités, soit dans la hiérarchie de vos groupes.


#3

Mon utilisateur n’a qu’un groupe qui n’a pas de parent
je n’ai pas ajouté de fonction dans l’objet Field


(David AZOULAY) #4

Ok mais quelle est la définition de ce groupe ?


#5


(David AZOULAY) #6

Je veux dire en termes de Grants


#7

Ah ! J’ai donné le grant sur cette fonction : (c’est la seule qui patle du Field) :


(David AZOULAY) #8

Et en outre je ne vois pas l’onglet “Profile” sur la définition de votre groupe, voici à quoi un formulaire de groupe devrait ressembler:

C’est peut être dans la liste des groupes liés à votre groupe au titre du profil qu’est la réponse


(David AZOULAY) #9

Retirez ce grant s’il n’a pas de raison d’être (et regardez si vous n’avez pas d’autres grants sur d’autres objets système dans votre groupe)


#10

Nickel merci beaucoup, j’'espère que ça va pas me faire découvrir pourquoi j’avais mis ce grant, mais surement un besoin que j’ai réaliser de manière différente


(David AZOULAY) #11

Oui il faut être prudent et bien savoir ce que l’on fait lorsqu’on attribue des droits sur les objets système à des utilisateur métier qui ne sont pas sensés faire de paramétrage

Reste quand même que votre formulaire de l’objet système groupe a une mauvaise tête car il manque 2 onglets… peut être avez vous avez touché aux droits système ou au template de cet objet…


#12

J’ai touché au template mais je vais y remédier


(David AZOULAY) #13

OK, à nouveau quand on touche aux objets système sans bonne raison on s’expose à des pb inexplicables…

Vous pouvez restaurer le paramétrage par défaut du template de cet objet depuis une instance vierge


#14

C’est ce que j’ai prévu de faire