Publipostage IE11 Mode responsive

4.0
Publipostage IE11 Mode responsive
0
Tags: #<Tag:0x00007fc3c866ebb0>
(Sébastien Hardy) #1

Le publipostage sur un objet n’est pas fonctionnel sour IE 11 en mode responive.

Version : Simplicité version4.0 patch level P22
Version IE : 11.0.9600.19236

(Ce n’est pas la dernière version de IE 11… version client)

0 Likes

(David AZOULAY) #2

IE 11 ça ne veut rien dire.

Quel est le moteur de rendering utilisé par IE ?
Est-ce bien le moteur IE 11 ou est-ce une version précédente (IE10, 9, 8, 7 , 6, …) ?

Nous mettons une directive pour dire à IE d’utiliser son moteur “edge” (ce qui ne veut pas dire le navigateur Edge mais le moteur le plus récent d’IE donc IE 11)

Chez de nombreux clients cette directive est overridée par un paramètre admin internet qui force le moteur à autre chose.

Simplicité fonctionne avec le moteur IE 11 pas avec un IE 11 utilisant un moteur plus ancien.

Cela étant dit IE 11 n’étant plus supporté en janvier 2020, à cette date nous ne le supporterons plus du tout. à cette date D’ici là on ne corrigera que les pbs fonctionnels (i.e. pas les pbs esthétiques).

NB: La fin du support IE 11 marquera aussi la fin de la UI legacy SImplicité

Bref une fois validé que c’est bien le moteur IE 11 qui fait le rendering merci de décrire précisement le pb avec des copies d’écran etc.

0 Likes

(David AZOULAY) #3

Je viens de faire qques tests d’export et de publications sur un IE 11 à jour (utilisant bien le moteur IE 11)

Je n’ai pas constaté de pb, je requalifie donc le post en Support avant d’avoir plus de détails sur le cas qui ne marche pas chez vous et/ou des infos précises sur la configuration du “IE 11” utilisé.

Peut être le pb est il dû à une règle relative aux ouvertures d’onglets/fenêtres. En effet la UI Simplicité ouvre les publications et les exports dans des onglets/fenetres à part

0 Likes

(David AZOULAY) #4

PS: pour afficher le user agent de l’IE 11 il faut appeler /health après s’être connecté à la UI
On voit alors cette entrée:

La partie du User Agent qui indique quel rendering engine est utilisé par IE c’est le rv:11.0
S’il n’y a pas ça ce n’est pas bon…

0 Likes

(Sébastien Hardy) #5

Je retesterai demain chez le client mais je pense que les IE sont bridés par l’admin.

0 Likes

(David AZOULAY) #6

OK, copie bien le user agent string.

Si ce n’est pas le moteur IE 11 à jour qui s’execute notre réponse est simple = la UI reponsive ne marchera pas et on ne fera rien pour la faire marcher.

Si c’est un moteur IE 10 ou IE 9 utilisez donc plutôt une version 3.2 de Simplicité (ou la UI legacy de la 4.0 qui marchera peut être) mais, comme indiqué dans https://docs.simplicite.io/documentation/compliance.md, ce sera de toute façon du “use at your own risks” car ces versions du moteur IE ne sont plus maintenues par Microsoft

Si c’est un moteur est IE 8 ou plus ancien aucune version de Simplicité encore maintenue ne marchera.

0 Likes

(Sébastien Hardy) #7

David,

Tu trouveras l’information ci dessous :
[Application]
ApplicationVersion=4.0
ContextPath=
ContextURL=https://WWWWWWW.io
SessionLogin=designer
SessionID=7F397F66C0F35DB62907C2D0DEF3C097
SessionUserAgent=Mozilla/5.0 (Windows NT 6.1; Trident/7.0; rv:11.0) like Gecko
ActiveSessions=10
EnabledUsers=4
TotalUsers=6
LastLoginDate=2019-03-27 11:27:48

0 Likes

(David AZOULAY) #8

Ok il y a bien rv:11.0 donc c’est à priori bien le moteur IE11 qui s’execute.

La différence Windows NT 6.1 vs Windows 10 c’est la version de l’OS Windows. Je ne sais pas trop expliquer les autres différences dans le user agent string : les WOW64 et Touch qui manquent ici.

Si tu constate un pb fonctionnel merci de le décrire précisément (idéalement avec des copies d’écran et/ou des logs : console navigateur et/ou serveur). Si on reproduit le pb on le corrigera mais on ne traitera pas les pbs purement esthétiques ne nuisant pas au fonctionnel (styles positionnement des divs etc.)

0 Likes