Retours Tests P24

Retours Tests P24
0
Tags: #<Tag:0x00007eff8c79fb48>

Bonjour,

j’ai déployé un module qui fonctionne très bien en P23 pour tester la P24.

Bonjour,
Merci pour ton retour, on va regarder pourquoi la valeur par défaut ne remonte pas sur l’IHM dans ce formulaire de mise à jour en masse.
Sinon je n’arrive pas à lire la vidéo jointe, peux-tu décrire le problème ou les messages des logs ou à l’écran ?

je veux ajouter une Ligne, je saisi les données. l’enregistrement ne fonctionne pas. le libellé saisi disparait.


si je clique sur annuler, rien ne se passe non plus

( @francois j’ai converti la video peut-être que ça marchera mieux ainsi )

Autre problème :
les listes de choix ne s’affiche pas entièrement et il n’est impossible de sélectionner que les 2 premières valeurs :
le liste contient 5 valeurs :


seules les 2 premières sont sélectionnables :

Lors de l’utilisation de la fonctionnalité “Créer en liste” (boucle), quand une donnée a été enregistrée, le bouton Annuler ne fonctionne pas, rien ne se passe. Par contre, il ferme le formulaire si on n’a rien enregistré.

Merci @Etienne

@rosanneQuily

  • UPSERT en liste :
    Le record en création était effectivement erroné (en fait il était avec des valeurs vides) ce qui doit expliquer aussi le problème à l’enregistrement (si pas de row_id=0 => pas de création). Je ne reproduis pas le problème de la vidéo suite à correction sur le boolean par défaut.

  • LISTE partielle
    La liste n’a aucune raison d’être partielle (sauf en cas de diagramme d’état). Je pense plutôt qu’elle passe “derrière” le div du tableau / pb de overflow css. On va voir si on peut la faire passer devant en retirant le style “responsive” du tableau lors de la sélection (le composant select2 remplace le select de base).

Pb avec les texte statiques
je ne retrouve pas un texte statique qui existant dans un template d’objet métier.

quand j’essaye de l’ajouter, je n’y arrive pas.
l’enregistrement d’un texte statique via “Editer Template” ne fonctionne pas.
la recherche du texte ajouté viale menu "Texte statique"ne me ramène rien.

et toujours sur les textes Statiques : dans l’éditeur de template, Retirer un texte statique ne fonctionne pas

  • Le pb de scroll sur les select2 est résolu

par contre le tableau n’est plus responsive lors de la sélection dans la liste, le scroll horizontal sera repris au niveau container (le tableau peut sortir de son container à droite comme pour un dropdown bootstrap).

  • Le bouton Fermer sur édition de liste est corrigé, c’était lié à une évolution récente

  • Texte statique : on va regarder mais il est possible d’insérer un texte existant ou directement dans la définition du template d’objet ou zone d’attributs

<div class="text" data-text="MY_TEXT_CODE"></div>
<h2 class="text" data-text="MY_TEXT_CODE"></h2>

j’ai un message dans les logs que je ne comprends pas :
2019-10-23 16:23:20,936 WARN [com.simplicite.util.ObjectDB] SIMPLICITE|https://localhost:10063/forpro|/forpro|WARN|system|com.simplicite.util.ObjectDB|resetFilter||Evénement: Deprecated method, please use resetFilters
dans mon code, j’utilise bien resetFilters() et pas resetFilter()

Il faut exporter vos modules en XML (le code étant exporté en CDATA) et y rechercher resetFilter pour savoir si cela vient d’un code d’objet, code partagé…

Je confirme que méthode deprecated resetFilter() (comme toutes le methodes deprecated) n’est utilisée nulle part dans le code Simplicité (ni dans le paramétrage système).

Elle est donc forcément appelée dans du code spécifique.

j’ai voulu supprimer le

directement dans le template et ça ne fonctionne pas. j’enregistre, je réouvre et le tag est toujours là