Critère de recherche sur un champ ramené ne fonctionne pas dans une activité

4.0
Critère de recherche sur un champ ramené ne fonctionne pas dans une activité
0
Tags: #<Tag:0x00007fcf15291238>

#1

Bonjour,

Une activité de recherche sur un objet A, propose tous les attributs qui possèdent une possibilité de recherche, qu’ils appartiennent à l’objet lui-même ou à un objet lié (attributs ramenés).
Or, seulement les attributs de l’objet lui même sont pris en contre dans les critères de recherches et non pas ceux ramenés.

Pour info, quand on filtre sur la liste de l’objet, tous les attributs de recherche fonctionnent.

Dans mon exemple, le champ “Nom” provient d’un autre objet. J’arrive à filtrer quand je suis sur la liste de l’objet “Locataire” et le filtre ne marche pas quand c’est dans un activité (il ramène toutes les lignes) :

Est-ce normal ?

Merci pour votre aide.
Abed.


#2

Bonjour à tous,

Je souhaite de très bonnes fêtes de fin d’année à tout le monde.

Je voudrais savoir si vous avez pu regarder ce pb qui est un peu bloquant pour nous étant donné que les filtres ne s’appliquent pas sur les attributs ramenés ?

Merci d’avance.

Abed.


(François Genestin) #3

C’est effectivement une vielle limitation héritée de la V3, on va améliorer ça en V4.


#4

Juste un petit rappel ;-)

On est vraiment gênés par cette limitation puisque beaucoup de nos objets sont liés. Exemple, un locataire, un tiers, un investisseur… est forcément une personne morale ou personne physique, donc forcément une recherche va se faire sur un objet lié et non pas sur l’objet lui-même.

Pareil, un bien, un bail… est lié à une adresse (donc objet lié)…

Donc dans 95% des cas, nos recherches seront basées sur des champs ramenés. D’où notre besoin urgent d’avoir cette possibilité.

Merci pour votre compréhension.

Abed.


(François Genestin) #5

L’évolution a été faite en master P23 qui est en cours de qualification, si vous êtes sur cette version vous pouvez tester la fonctionnalité.