Image simplicité et connexion SSL vers la base externe de données

Image simplicité et connexion SSL vers la base externe de données
0
Tags: #<Tag:0x00007fed44f09a40>

Nous utilisons vos images Docker pour déployer une instance simplicité.

Une page de votre documentation (https://www.simplicite.io/resources/documentation/90-operation/docker.md#externaldatabase) indique clairement comment s’interfacer avec une base de données externe.

Nous avons besoin de sécuriser la communication entre le serveur simplicité et la base de données en utilisant une connexion ssl.

Je n’ai pas trouvé comment configurer cela, pouvez-vous m’aider dans ma démarche ?

Très bonne journée.

Simplicité utilise une connectivité JDBC. Les variables d’environnement que l’on passe au container Docker server à construire l’URL JDBC.

Pouvez vous m’indiquer quelle sont les options de l’URL de connexion JDBC que vous avez besoin d’utiliser exactement ?

Merci

Nous avons besoin de l’option ssl=true
Et nous ajouterons un certificat au trustore JAVA dans le container docker.

Merci pour votre aide.

OK, je suis en train d’ajouter le support en standard de l’option ssl=true je vous previens lorsque c’est pret (en l’état c’est faisable mais de manière peu pratique)

Pour ce qui est d’ajouter un certificat dans l’image (y compris dans le truststore Java) la bonne manière de faire est de builder une image dérivée de la notre avec le Dockerfile suivant:

FROM simplicite/platform:latest
COPY mycertificate.crt /etc/pki/ca-trust/source/anchors/
RUN /bin/update-ca-trust extract

Le point sur le certificat custom est documenté ici: https://docs.simplicite.io/documentation/90-operation/docker.md#addcertificate

PS: Juste pour être sûr votre base de données c’est bien du PostgreSQL ?

Oui c’est ça.
Merci beaucoup pour vos réponses.

On a ajouté le support pour la variable DB_SSL=<true|false> dans les images Docker.

En démarrant le container avec -e DB_SSL=true avec une base PostgreSQL l’URL JDBC configurée au niveau de l’instance sera jdbc:postgresql://<host>:<port>/<name>?ssl=true

Cela reste néanmoins expérimental à ce stade donc merci de nous faire un retour pour savoir si ça marche dans votre cas.

Très bien.
Nous allons tester la configuration dans la semaine à venir et nous vous tiendrons au courant.
Encore merci pour la rapidité des réponses.