Problème d'insert en base via API

Problème d'insert en base via API
0
Tags: #<Tag:0x00007f85359793e0>

Bonjour,
Je rencontre un problème après plusieurs (5 en moyenne) insertions de données dans une table via des appels API.
Je vous écrit un peu de contexte.
Je travaille sur une base de recette en version P23 de Juillet 2019 (sachant que je ne peux pas mettre à jour vers une version plus récente car mon environnement de dev est en P24 Alpha pour tester la fonctionnalité des APIs imbriquées).
Lors de l’appel API en POST sur une ressource du modèle l’insert en BDD se passe correctement jusqu’à un certains nombre d’appels (5 en moyenne). A ce moment, soit l’insert échoue, soit les données insérées sont incomplètes.
En regardant dans les logs, on constate, au moment où l’appel qui “échoue” est réalisé, que le socle à essayé de faire un Select dans une table d’historique qui n’existe pas (ou plus je ne connais pas le passif complet du projet…). En regardant la configuration de l’objet en question, j’ai pu voir que l’historique est désactivé.
En revanche, il est timestampé avec l’algorithme optimiste.
Seriez-vous au courant de ce genre de problème et savez-vous si cela a été corrigé dans une version postérieure à la mienne. Auquel cas, je vais attendre la release de la P24 pour mettre à jour l’ensemble de mes environnements.

Merci d’avance.

Health :

1 Like

Non ce que vous décrivez ne me dit rien.

Merci de me préciser de quel projet/instance vous parlez, de fournir votre paramétrage (si on ne parle pas d’une instance a laquelle on a accès), de fournir les logs, les appels effectués, etc.