Bouton Create inopérant sur un lien affiché en pillbox

Tags: #<Tag:0x00007f491686f518>

Bonjour,

J’ai configuré le lien d’un business object vers un autre en rendering “pillbox with creation”, l’affichage correspond à mon attente mais le bouton Create ne fait rien

image

/health :

Version=4.0.P24
BuiltOn=2020-09-08 14:02 (revision cc3e1c0a38d7b0549d655541696b9efd34201031)

Merci d’avance pour votre aide !
Emmanuelle

Bonjour,

Ce bouton permet de créer ce que vous saisissez, ça ne lance pas un écran de création.

Il faut pour que ça fonctionne

  • avoir les droits de création de l’objet lié + N,N éventuelle.
  • que l’objet ait une clé fonctionnelle mono-champ, et aucun autre champ obligatoire sans valeur par défaut… pour pouvoir créer simplement l’objet lié en ne renseignant qu’un seul champ.

On pourrait imaginer d’autres usages en fonction de votre besoin, mais je ne vois pas d’anomalie à ce stade, je passe le post en support.

Merci de votre réponse rapide, je pensais en effet que ça devait ouvrir un écran mais sur un objet de type pillbox c’est vrai ce n’est pas nécessaire.
Ca serait top à l’occasion d’avoir un petit message d’erreur quand la ligne ne peut être créée (champ vide ou valeur déjà existante par exemple)

Oui c’est vrai, on peut mieux gérer les indications puisque le bouton est actif par défaut.
Et pour un cas complexe (non mono-champ) afficher le formulaire de création de l’objet dans un popup.
Du coup on passe en feature request ;-)

2 Likes

Un message de type champ obligatoire + l’erreur remontée par le back (comme “existe déjà”) ont été ajoutés en V5 et backporté en V4.P24.

1 Like